PAT A 1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be N~c~/N~t~*100%, where N~c~ is the number of distinct common numbers shared by the two sets, and N~t~ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=10^4^) and followed by M integers in the range [0, 10^9^]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

问题不大,就是查找的时候用find,不然最后一组数据会超时

#include<cstdio>
#include<set>
using namespace std;

set<int>Set[55];

void find(int a, int b) {
    int count = 0;
    for (set<int>::iterator it = Set[a].begin(); it != Set[a].end(); it++) {
        if (Set[b].find(*it)!=Set[b].end()) count++;
    }
    printf("%.1f%%\n", 100.0*count / (Set[a].size() + Set[b].size() - count));
}

int main() {
    int n;
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        int num, digit;
        scanf("%d", &num);
        while (num--) {
            scanf("%d", &digit);
            Set[i].insert(digit);
        }
    }

    int query;
    scanf("%d", &query);
    while (query--) {
        int num1, num2;
        scanf("%d %d", &num1, &num2);
        find(num1, num2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Joah_Ge/article/details/81098732