PAT甲级-1063-Set Similarity(set集合+vector)

Given two sets of integers, the similarity of the sets is defined to be N​c /N​t×100%, where N​c is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​ ) and followed by M integers in the range [0,10​9 ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input :
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output :
50.0%
33.3%

代码如下

#include<iostream>
#include<set>
#include<vector>
using namespace std;
int main()
{
	int n,m,k,tmp,x,y;
	scanf("%d", &n);
	vector<set<int> > v(n+1);
	for(int i = 1; i <= n; i++){
		scanf("%d", &m);
		for(int j = 0; j < m; j++){
			scanf("%d", &tmp);
			v[i].insert(tmp);	
		}
	}
	scanf("%d", &k);
	for(int i = 0; i < k; i++){
		scanf("%d %d", &x, &y);
		set<int>:: iterator it;
		int nc = 0,nt = v[y].size();
		for(it = v[x].begin(); it != v[x].end();it++){
			if(v[y].find(*it) != v[y].end()){
				nc++;
			}else{
				nt++;
			}
		}
		printf("%.1f%\n", (double)nc/nt*100);
	}
	return 0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_42437577/article/details/104170768