PAT.A1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be N~c~/N~t~*100%, where N~c~ is the number of distinct common numbers shared by the two sets, and N~t~ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=10^4^) and followed by M integers in the range [0, 10^9^]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
#include<string>
#include<set>
using namespace std;

int main() {
	int n;
	scanf("%d", &n);
	vector<set<int> > num;
	for (int i = 0; i < n; i++) {
		int m;
		scanf("%d", &m);
		set<int> tmp;
		for (int j = 0; j < m; j++) {
			int tm;
			scanf("%d", &tm);
			tmp.insert(tm);
		}
		num.push_back(tmp);
	}
	int k;
	scanf("%d", &k);
	set<int>::iterator it1,it2;
	for (int i = 0; i < k; i++) {
		int s1, s2;
		int n1 = 0;
		scanf("%d%d", &s1, &s2);
		for (it1 = num[s1 - 1].begin(); it1!= num[s1 - 1].end(); it1++) {
			if (num[s2 - 1].end() != num[s2 - 1].find(*it1)) n1++;
			
		}
		printf("%.1lf%%\n", 100.0*n1 / (num[s1-1].size() + num[s2 - 1].size()-n1));
	}
	
	
return 0;
}

猜你喜欢

转载自blog.csdn.net/mokena1/article/details/80823134