【HDU2048】数塔(简单动态规划/DP)

数塔

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20786 Accepted Submission(s): 12486

Problem Description

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
这里写图片描述
已经告诉你了,这是个DP的题目,你能AC吗?

Input

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

Output

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

Sample Input

1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

解析:就是将一条一条路线找这种方式简化为部分问题。从倒数第二层开始,不断向上。并将这层的下次的可以连接的两个数字中选大的加上去,这样,加到第一层时,第一层就是最大的数字了。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e2+5;

int map[maxn][maxn];
int dp[maxn][maxn];
int n;

int max(int a,int b){
    return a>b ? a:b;
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        for( int i=1 ; i<=n ; i++ ){
            for( int j=1 ; j<=i ; j++ ){
                scanf("%d",&map[i][j]);
            }
        }
        for( int i=1 ; i<=n ; i++ ){
            dp[n][i]=map[n][i];
        }
        for( int i=n-1 ; i>=1 ; i-- ){
            for( int j=1 ; j<=i ; j++ ){
                dp[i][j] = map[i][j] + max( dp[i+1][j],dp[i+1][j+1] );
            }
        }
        printf("%d\n",dp[1][1]);    
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/51969961