HDU - 1003 Max Sum DP

HDU - 1003 Max Sum

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string.h>
using namespace std;
int main()
{
    
    
    int n,t;
    cin>>n;
    t=n;
    while(n--)
    {
    
    
        int i,m,a[100010],dp[100010]={
    
    0},sum=0,k=1;
        cin>>m;
        for(i=1;i<=m;i++)
        {
    
    
            cin>>a[i];
        }
        dp[1]=a[1];
        sum=a[1];
        for(i=2;i<=m;i++)
        {
    
    
            if(sum<0||sum+a[i]<0)
            {
    
    
                sum=0;
            }
            sum=sum+a[i];
            dp[i]=max(dp[i-1],sum);
            if(dp[i-1]<sum)
            {
    
    
                k=i;
            }
        }
        int ans=0,start=1;
        for(i=k;i>0;i--)
        {
    
    
            ans+=a[i];
            if(ans==dp[m])
            {
    
    
                start=i;
            }
        }
        printf("Case %d:\n",t-n);
        printf("%d %d %d\n",dp[m],start,k);
        if(n!=0)
        {
    
    
            printf("\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_51996479/article/details/114108698