G - 7 HDU - 1003 Max Sum

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

问题链接:https://vjudge.net/contest/277768#problem/G

问题分析: 找出最大值时标记头与尾。

AC代码如下:

#include<iostream>
using namespace std;
const int N = 100000;
int a[N];
int main()
{
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		int b;
		cin >> b;
		int sum = -5;
		int maxx = -5;
		int temp, head, foot;
		for (int j = 1; j <= b; j++)
			cin >> a[j];
		for (int k = 1; k <= b; k++)
		{
			if (sum < 0)
			{
				sum = a[k];
				temp = k;
			}
			else
				sum += a[k];
			if (sum > maxx)
			{
				maxx = sum;
				head = temp;
				foot = k;
			}
		}
		cout << "Case " << i << ":" << endl;
		cout << maxx << ' ' << head << ' ' << foot<<endl;
		if (i != n)cout << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43966523/article/details/86632798