HDOJ-4004 The Frog's Games

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6113    Accepted Submission(s): 2967


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
   
   
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
   
   
4 11
这个题主要是分析好bool函数,主函数中要注意使用二分,而bool函数要注意中间在判断不能跳跃的时候,一定要防止无限循环,加一个if判断语句(在这个时候return)就行啦。
bool中循环比较复杂,一枚大神给讲的。
代码在下边:
#include <bits/stdc++.h>
using namespace std;
const int maxn=5*1e5+10;
int a[maxn],L,m,n;
bool jump(int t)
{
	int cnt=1,last=0;
	for(int i=0;i<=m;)
	{
		if(t+last>=a[i])
			i++;
		else{
			if(last==a[i-1]) return false;
			last=a[i-1];cnt++;
		}
	}
	return cnt<=n;
}
int main()
{
	while(~scanf("%d%d%d",&L,&m,&n))
	{
		for(int i=0;i<m;i++)
		{
			scanf("%d",a+i);
		}
		sort(a,a+m);a[m]=L;
		int l=1,r=L,ans=0;
		while(l<=r)
		{
			int mid=(l+r)>>1;
			if(jump(mid)){
				r=mid-1;
				ans=mid;
			}
			else l=mid+1;
		}
		printf("%d\n",ans);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Poseidon__ming/article/details/52039002