贪心思想简单题(出售月饼)

问题

1070 Mooncake (25 分)
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
结尾无空行
Sample Output:
9.45

思路

贪心思想,按照单价从高到低对各种月饼进行排序。每次挑选单价最高的出售,这样就能获得最大利润。

代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1010;
struct mooncake{
    
    
    float total;
    float price;
};

vector<mooncake> all;
bool cmp(mooncake a,mooncake b){
    
    
    return a.price>b.price;
}
int main(){
    
    
    int n;
    float m,temp;
    float f,ans=0;
    cin>>n>>m;
    for (int i = 0; i < n; ++i) {
    
    
        cin>>temp;
        mooncake cake;
        cake.total = temp;
        all.push_back(cake);
    }
    for (int j = 0; j < n; ++j) {
    
    
        cin>>f;
        all[j].price = f/all[j].total;
    }
    sort(all.begin(),all.end(),cmp);
    for (int k = 0; k < all.size(); ++k) {
    
    
        if(m==0){
    
    
            printf("%.2f",ans);
            return 0;
        }
        if(m<=all[k].total){
    
      //需求小于当前月饼数量
            ans = ans + all[k].price*m;
            m = 0;
        }
        else if(m>all[k].total){
    
    
            ans = ans + all[k].price*all[k].total;
            m = m - all[k].total;
        }
    }
    printf("%.2f",ans);
    return 0;
}

总结

注意点:
1.需求量和各种月饼的库存量要定义成float 不然会有样例过不了。
2.考虑边界情况,需求量大于所有月饼库存量之和的处理。

猜你喜欢

转载自blog.csdn.net/qq_19272233/article/details/119423241
今日推荐