散列表空间换时间

问题

1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10
5
coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
5
, the total number of coins) and M (≤10
3
, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V
1

and V
2

(separated by a space) such that V
1

+V
2

=M and V
1

≤V
2

. If such a solution is not unique, output the one with the smallest V
1

. If there is no solution, output No Solution instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
结尾无空行
Sample Output 1:
4 11
结尾无空行
Sample Input 2:
7 14
1 8 7 2 4 11 15
结尾无空行
Sample Output 2:
No Solution

思路

以m作为数组下标,统计出现的个数。

代码

用以下的方法会有一个测试用例超时,总分卡在23分:

#include <bits/stdc++.h>
using namespace std;

int main(){
    
    
    int n,m,temp;
    set<int> coins;
    cin>>n>>m;
    for (int i = 0; i < n; ++i) {
    
    
        cin>>temp;
        for (set<int>::iterator i = coins.begin();i!=coins.end();++i) {
    
    
            if(temp+*i==m && temp==*i){
    
    
                cout<<*i<<" "<<temp;
                return 0;
            }

        }
        coins.insert(temp);
    }
    for (set<int>::iterator i = coins.begin();i!=coins.end();++i) {
    
    
        for (set<int>::iterator j = --coins.end();j!=i;--j) {
    
    
            if(*i+*j==m){
    
    
                cout<<*i<<" "<<*j;
                return 0;
            }
        }

    }
    cout<<"No Solution";
    return 0;
}

满分的代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;
int hashTable[maxn];
int main(){
    
    
    int n,m,temp;
    fill(hashTable,hashTable+maxn,0);
    cin>>n>>m;
    for (int i = 0; i < n; ++i) {
    
    
        cin>>temp;
        hashTable[temp]++;
    }
    for (int j = 1; j < m; ++j) {
    
    
        if(hashTable[j] && hashTable[m-j]){
    
    
            if(j==m-j && hashTable[j]<=1){
    
    
                continue;
            }
            printf("%d %d",j,m-j);
            return 0;
        }
    }
    printf("No Solution");
    return 0;
}

总结

散列法就是用空间来换取时间的,当出现超时的现象时可以考虑使用散列法。

猜你喜欢

转载自blog.csdn.net/qq_19272233/article/details/119422300