【PAT】A1031. Hello World for U (20)

Description:
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
h    d
e     l
l     r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible — that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!

Sample Output:
h      !
e      d
l       l

lowor

//NKW 甲级真题1045
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
const int maxn = 81;
int main(){
	char inf[maxn];
	scanf("%s", inf);
	int len = strlen(inf);
	int n1, n2, k = 0, l = len - 1;
	n1 = (len + 2) / 3;                    //n1,n2这两个关系式的推出非常重要
	n2 = len - 2 * n1 + 2;
	for (int i = 0; i < n1 - 1; i++){
		for (int j = 0; j < n2; j++){
			if (j == 0)
				printf("%c", inf[k++]);
			if (j > 0 && j < n2 - 1)
				printf(" ");
			if (j == n2 - 1)
				printf("%c\n", inf[l--]);
		}
	}
	for (int i = k; i <= l; i++)
		printf("%c", inf[i]);
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80904995