PAT甲级--1031 Hello World for U(20 分)【模拟】

1031 Hello World for U(20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

解题思路:这题也是简单题,就是自己在存的时候不小心把它给存反了, 改回来就过了,具体见代码

#include<bits/stdc++.h>
using namespace std;
char a[30][30];
int main(void)
{
	for(int i=0;i<30;i++)
	{
		for(int j=0;j<30;j++)
		{
			a[i][j]=' ';//先全部赋值成空格
		}
	}
	string s;
	cin>>s;
	int len=s.size();
	int n1=(len+2)/3;
	int n2=n1+(len+2)%3;
	for(int i=0;i<n1;i++)
	{
		a[i][0]=s[i];
		a[i][n2-1]=s[len-i-1];
	}
	for(int i=1;i<n2;i++)
	{
		a[n1-1][i]=s[i+n1-1];
	}
    for(int i=0;i<n1;i++)
    {
    	for(int j=0;j<n2;j++)
    	{
    		printf("%c",a[i][j]);
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82051122
今日推荐