PAT 1031 Hello World for U (20)

1031 Hello World for U (20)(20 分)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路:

这题的关键就在于题目给出的那个式子n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } 并且n1 + n2 + n3 - 2 = N,那么我们不妨把n2从3到N循环,n1=(N+2-n2)/2,显然n2越小n1越大,现在又要n1<=n2,那么可以得出(N+2-n2)/2<=n2,变形得n2>=(N+2)/3。但是要注意这样求出的满足这个式子的最小的n2不一定能要N+2-n2成为偶数,所以还要加个判断。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

int main()
{
	string str, s1 = "", s2 = "", s3 = "";
	int n1, n2, n3;
	cin >> str;
	int N = str.length();
	n2 = (N + 2) / 3;
	if ((N + 2) % 3)
		n2++;
	if ((N + 2 - n2) % 2)
	{
		n2++;
		n1 = (N + 2 - n2) / 2;
	}
	else
		n1 = (N + 2 - n2) / 2;
	n3 = n1;
	for (int i = 0; i < n1 - 1; i++)
	{
		cout << str[i];
		for (int j = 0; j < n2 - 2; j++)
			cout << " ";
		cout << str[N - 1 - i] <<endl;
	}
	for (int i = 0; i < n2; i++)
		cout << str[n1 - 1 + i];
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81488806