1031 Hello World for U(20)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路:这道题最主要的就是n1,n2,n3的求值,要让它们的值最接近。 

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string str;
	cin>>str;
	int len=str.length();
	int n1=(len+2)/3;
	int n2=len-2*n1+2;
	for(int i=0;i<n1-1;i++)
	{
		for(int j=0;j<n2;j++)
		{
			if(j==0)
			cout<<str[i];
			else if(j==n2-1)
			cout<<str[len-i-1];
			else
			cout<<" ";
		}
		cout<<endl;
	 } 
	 for(int i=1;i<=n2;i++)
	 {
	 	cout<<str[n1+i-2];
	 }
 } 

猜你喜欢

转载自blog.csdn.net/Fcity_sh/article/details/83892101