PAT 甲级 1031 Hello World for U(模拟)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

Analysis:

n1 and n3 should be the max value which can not be longer than n2.

c++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	//freopen(".txt","r",stdin);
	string s;
	cin>>s;
	int len=s.length()+2;
	int n1=len/3,n2=len/3,n3=len/3+len%3;
	for(int i=0;i<n1-1;i++){
		cout<<s[i];
		for(int j=0;j<n3-2;j++)
			cout<<" ";
		int index=s.length()-1-i;
		cout<<s[index]<<endl;
	}
	cout<<s.substr(n1-1,n3);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/82995352