Network( POJ - 1144 )(割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output
The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2
Hint
You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.
代码:


#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
vector<int>g[110];//邻接表 
int flag[110];//是否是割点 
int low[110];//能访问到的最小时间戳 
int dfn[110];//当前点的时间戳 
int id,ans,n;//时间戳、答案、点。 

void dfs(int cur,int father)//当前点和它的父节点 
{
	int child=0,i;//孩子个数 
	id++;//时间戳 
	low[cur]=id;//当前点能访问到的最小时间戳
	dfn[cur]=id;//当前点的时间戳  
	for(i=0;i<g[cur].size();i++)
	{
		int u=g[cur][i];//与当前点相连的点 
		if(!dfn[u])//如果是第一次访问 
		{
			child++;//当前点孩子数加1 
			dfs(u,cur);
			low[cur]=min(low[cur],low[u]);//更新能访问到的最小时间戳,因为u与当前点相连所以更新为u点能访问到的最小时间戳 
			if(cur!=1&&low[u]>=dfn[cur])//如果不是根节点,且存在一个节点在删除当前点的情况下不能再访问到当前点的祖先 
			flag[cur]=1;                //则当前点是割点 
			if(cur==1&&child>=2)//如果当前点是割点且有两个以上的子节点 //则当前点是割点
			flag[cur]=1;
		}
		else if(u!=father)//如果点曾经被访问过,且不是当前点的父节点,则更新当前点能访问到的最小时间戳
		{
			low[cur]=min(low[cur],dfn[u]);
		}
	}
}

int main(void)
{
	while(~scanf("%d",&n)&&n)
	{
		int x,y,i;
		memset(low,0,sizeof(low));
		memset(dfn,0,sizeof(dfn));
		ans=0;
		memset(flag,0,sizeof(flag));
		for(i=0;i<=n;i++)//清空容器 
		g[i].clear();
		while(~scanf("%d",&x)&&x)
		{
			while(scanf("%d",&y))
			{
				g[x].push_back(y);
				g[y].push_back(x);//双向 
				if(getchar()=='\n')
				break;
			}
		}
		dfs(1,1);//从1号顶点开始遍历 
		for(i=1;i<=n;i++){
			if(flag[i])
			ans++;
		}
		printf("%d\n",ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/80615283