poj1144 Network——割点

Network

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16028 Accepted: 7248

- Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

  • Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

  • Output

The output contains for each block except the last in the input file one line containing the number of critical places.

  • Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
  • Sample Output
1
2
  • Hint

You need to determine the end of one line.In order to make it’s easy to determine,there are no extra blank before the end of each line.

强连通(strongly connected): 在一个有向图G里,设两个点 a b 发现,由a有一条路可以走到b,由b又有一条路可以走到a,我们就叫这两个顶点(a,b)强连通。

强连通图: 如果 在一个有向图G中,每两个点都强连通,我们就叫这个图,强连通图。

强连通分量strongly connected components):在一个有向图G中,有一个子图,这个子图每2个点都满足强连通,我们就叫这个子图叫做 强连通分量

tarjan求割点的模板

何为割点?

也就是题目中的关键点。在一个无向图中,去掉一个点,这个无向图会变成多个子图,那么这个点就叫做割点

同理,割边也是如此,如果去掉一条边,能让无向图变成多个子图,那么这条边叫做割边,所谓的桥。

tarjan求割点
dfn:代表这个节点的深度
low:代表这个节点能通过反向边能到达到最浅深度(初始设为这个节点的深度)
如果u为割点,当且仅当满足下面的1/2
1、如果u为树根,那么u必须有多于1棵子树
2、如果u不为树根,那么(u,v)为树枝边,当Low[v]>=DFN[u]时。

条件1的意思是若为根,下面如果只有一颗子树,也就是整个图是强连通,那么去掉根节点,肯定不会变成多个子图,因此也不会成为割点。只有大于一颗子树,去掉根节点,才会有两个或者2个以上的子图,从而才能成为割点

条件2,若u不为树根,那么u肯定有祖先,如果存在Low【v】>=DFN【u】时,表示u的子孙只能通过u才能访问u的祖先,这也就是说,不通过u,u的子孙无法访问u的祖先。

#include <iostream>
#include <map>
#include <iterator>
#include <algorithm>
#include <vector>
#include <queue>
#include <list>
#include <cmath>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <string>
#include <sstream>
#define INF 1e6
const int maxn=110;
using namespace std;
#define N 1010
int n,m,cnt,dep,children,cut[N],low[N],dfn[N];
bool vis[N];
vector<int>grap[N];
void init(){
    memset(low,0,sizeof low);
    memset(dfn,0,sizeof dfn);
    memset(cut,0,sizeof cut);
    memset(vis,0,sizeof vis);
    memset(grap,0,sizeof grap);
}
void tarjan(int v){
    low[v]=dfn[v]=++dep;
    for(int i=0;i<grap[v].size();i++){
        int w=grap[v][i];
        if(!dfn[w]){
            tarjan(w);
            low[v]=min(low[v],low[w]);
            if(low[w]>=dfn[v]&&v!=1)
                cut[v]++;
            else if(v==1)
                children++;
        }
        else{
            low[v]=min(low[v],dfn[w]);
        }
    }
}

int main(){
    while(scanf("%d",&n)&&n){
        int u,v;
        init();
        dep=0;children=0;cnt=0;
        while(scanf("%d",&u)&&u){
            while(getchar()!='\n'){
                scanf("%d",&v);
                grap[u].push_back(v);
                grap[v].push_back(u);
            }
        }
        tarjan(1);
        for(int i=1;i<=n;i++)
            if(cut[i])
                cnt++;
        if(children>1)
            cnt++;
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/80344446
今日推荐