POJ1144 Network【割点】

Network

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11914   Accepted: 5519

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

问题描述:给出一个无向图,求出有多少个割点。有若干组测试数据。每一组测试数据的第一行有一个整数 n,表示有 n
(1<=n<100)个点,n=0 时测试数据结束。接下来有若干行,每一行第一个整数 u 表示这一行描述的是以 u 为起点的边,接下来有若干个整数 vi 表示有一条边 u-vi,u=0 时表示这一组测试数据结束。对于每一组测试数据,输出一个整数,即有多少个割点。

解题思路:Tarjan算法

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>

using namespace std;

const int N=105;

bool flag[N];//标记每个点是否为割点
int dfn[N],low[N],pre[N];
int index,n;

vector<int>g[N];

void Tarjan(int u,int father)
{
	pre[u]=father;
	dfn[u]=low[u]=index++;
	for(int i=0;i<g[u].size();i++)
	{
		int v=g[u][i];
		if(!dfn[v])
		{
			Tarjan(v,u);
			low[u]=min(low[u],low[v]);
		}
		else if(v!=father)//连回到父节点的回边不考虑,否则求不出桥
		  low[u]=min(low[u],dfn[v]); 
	}
} 

//计算割点 
void solve()
{
	int num=0;
	for(int i=0;i<=n;i++) 
	  dfn[i]=low[i]=pre[i]=flag[i]=0;
	index=0;
	Tarjan(1,0);
	for(int i=2;i<=n;i++)
	{
		int v=pre[i];
		if(v==1)
		  num++;//DFS树中根节点有几个子树
		else if(dfn[v]<=low[i])
		  flag[v]=true; 
	}
	if(num>1)
	  flag[1]=true;
	//统计割点的个数 
	int ans=0;
	for(int i=1;i<=n;i++)
	  if(flag[i])
	    ans++;
	printf("%d\n",ans);
}

int main()
{
	while(scanf("%d",&n)&&n)
	{
		for(int i=0;i<=n;i++)
		  g[i].clear();
		int u,num,v;
		while(scanf("%d",&u)&&u)
		{
			while(getchar()!='\n') 
			{
				scanf("%d",&v);
				g[u].push_back(v);
				g[v].push_back(u); 
			}
		}
		solve(); 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84928193
今日推荐