POJ 1144 Network【割点】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/87877574

题目:

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just ‘0’. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

题目大意:

       求割点,多组输入。

解题思路:

       求割点模板题 。

实现代码:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<queue>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;

const int maxn=1005;
int n,low[maxn],dfn[maxn],id[maxn],scc_cnt,dfstime,cut[maxn];
vector<int> v[maxn];

void init(){
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(id,0,sizeof(id));
    memset(cut,0,sizeof(cut));
    scc_cnt=0;
    dfstime=0;

    for(int i=0;i<maxn;i++)
        v[i].clear();
}

void tarjan(int x,int f){
    int son=0;
    dfn[x]=low[x]=++dfstime;

    for(int i=0;i<v[x].size();i++){
        int to=v[x][i];
        if(!dfn[to]){
            son++;
            tarjan(to,x);
            low[x]=min(low[x],low[to]);
            if(low[to]>=dfn[x])
                cut[x]=1;
        }
        else if(dfn[to]<dfn[x]&&to!=f){
            low[x]=min(low[x],dfn[to]);
        }
    }
    if(f<0&&son==1)
        cut[x]=0;
}

int main(){
    while(~scanf("%d",&n), n){
        init();
        int x,y;
        while(scanf("%d",&x),x){
            while(getchar()!='\n'){
                scanf("%d",&y);
                v[x].push_back(y);
                v[y].push_back(x);
            }
        }
        tarjan(1,-1);
        int ans=0;
        for(int i=1;i<=n;i++)
            if(cut[i]) ans++;
        printf("%d\n",ans);
    }
    return 0;
}

PS:

        使用 next[ ] 会出现编译错误(CE)。

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/87877574
今日推荐