HDU1394 ZOJ1484 Minimum Inversion Number【树状数组】

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23305    Accepted Submission(s): 13837


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
 
  
101 3 6 9 0 8 5 7 4 2
 

Sample Output
 
  
16
 

Author
CHEN, Gaoli
 

Source

问题链接HDU1394 ZOJ1484 Minimum Inversion Number

问题描述:(略)

问题分析:这个问题用树状数组来解决,先占个位置不解释。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* HDU1394 ZOJ1484 Minimum Inversion Number */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 5000;
int a[N + 1], n;
int num[N + 1];

int lowbit(int i)
{
    return i & -i;
}

void update(int i, int v) //更新函数
{
    while(i <= n) {
        a[i] += v;
        i += lowbit(i);
    }
}

int sum(int i)      //求和函数
{
    int sum = 0;
    while(i > 0) {
        sum += a[i];
        i -= lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d", &n)) {
        for(int i = 1; i <= n; i++) {
            scanf("%d", &num[i]);
            num[i]++;
        }

        int ans = 0;
        memset(a, 0, sizeof(a));
        for(int i = 1; i <= n; i++) {
            update(num[i], 1);
            ans += i - sum(num[i]);
        }

        int t = ans;
        for(int i = 2; i <= n; i++) {
            t += n - 2 * num[i - 1] + 1;
            if(t < ans)
                ans = t;
        }

        printf("%d\n", ans);
    }

    return 0;
}



猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80921225