城堡问题(深搜入门)

     1   2   3   4   5   6   7  
   #############################
 1 #   |   #   |   #   |   |   #
   #####---#####---#---#####---#
 2 #   #   |   #   #   #   #   #
   #---#####---#####---#####---#
 3 #   |   |   #   #   #   #   #
   #---#########---#####---#---#
 4 #   #   |   |   |   |   #   #
   #############################
           (图 1)

   #  = Wall   
   |  = No wall
   -  = No wall

图1是一个城堡的地形图。请你编写一个程序,计算城堡一共有多少房间,最大的房间有多大。城堡被分割成mn(m≤50,n≤50)个方块,每个方块可以有0~4面墙。 
Input程序从标准输入设备读入数据。第一行是两个整数,分别是南北向、东西向的方块数。在接下来的输入行里,每个方块用一个数字(0≤p≤50)描述。用一个数字表示方块周围的墙,1表示西墙,2表示北墙,4表示东墙,8表示南墙。每个方块用代表其周围墙的数字之和表示。城堡的内墙被计算两次,方块(1,1)的南墙同时也是方块(2,1)的北墙。输入的数据保证城堡至少有两个房间。Output城堡的房间数、城堡中最大房间所包括的方块数。结果显示在标准输出设备上。 
Sample Input
4 
7 
11 6 11 6 3 10 6 
7 9 6 13 5 15 5 
1 10 12 7 13 7 5 
13 11 10 8 10 12 13 

Sample Output

5
9

题目解答比较简单,唯一的问题在于如果我不用book数组来标志,而对maze数组内遍历过的数取负,结果会不不正确,一直不明白为什么会这样。
#include<iostream>
#include<cstring>
using namespace std;
int maze[60][60],M,N;
int book[60][60];
int roomnum=0,maxroom=0,room;//记录房间数、最大房间、目前房间大小; 
void dfs(int x,int y)
{
	
	if(book[x][y]) return;
	
	room++;
	
	book[x][y]=1;
	
	if((maze[x][y]&1)==0) dfs(x,y-1);

	if((maze[x][y]&2)==0) dfs(x-1,y);

	if((maze[x][y]&4)==0) dfs(x,y+1);

	if((maze[x][y]&8)==0) dfs(x+1,y);
}
int main()
{
	cin>>M>>N;
	memset(book,0,sizeof(book));
	for(int i=0;i<M;i++) for(int j=0;j<N;j++) cin>>maze[i][j];
	for(int i=0;i<M;i++) for(int j=0;j<N;j++)
	{
		if(!book[i][j]) 
		{
			room=0;
			roomnum++;//更新房间数 
			dfs(i,j);
			maxroom=maxroom>room?maxroom:room;//更新最大房间 
		}
	} 
	cout<<roomnum<<endl<<maxroom<<endl;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/jack_jxnu/article/details/80958411