城堡问题(深搜)

描述

     1   2   3   4   5   6   7  
   #############################
 1 #   |   #   |   #   |   |   #
   #####---#####---#---#####---#
 2 #   #   |   #   #   #   #   #
   #---#####---#####---#####---#
 3 #   |   |   #   #   #   #   #
   #---#########---#####---#---#
 4 #   #   |   |   |   |   #   #
   #############################
           (图 1)

   #  = Wall   
   |  = No wall
   -  = No wall


图1是一个城堡的地形图。请你编写一个程序,计算城堡一共有多少房间,最大的房间有多大。城堡被分割成mn(m≤50,n≤50)个方块,每个方块可以有0~4面墙。

输入

程序从标准输入设备读入数据。第一行是两个整数,分别是南北向、东西向的方块数。在接下来的输入行里,每个方块用一个数字(0≤p≤50)描述。用一个数字表示方块周围的墙,1表示西墙,2表示北墙,4表示东墙,8表示南墙。每个方块用代表其周围墙的数字之和表示。城堡的内墙被计算两次,方块(1,1)的南墙同时也是方块(2,1)的北墙。输入的数据保证城堡至少有两个房间。

输出

城堡的房间数、城堡中最大房间所包括的方块数。结果显示在标准输出设备上。

样例输入

4 
7 
11 6 11 6 3 10 6 
7 9 6 13 5 15 5 
1 10 12 7 13 7 5 
13 11 10 8 10 12 13 

样例输出

5
9

本题就可以简化成求非连通图的个数及最大节点数,自然就想到图的遍历

#include<iostream>
#include<cstdio>
#include<cstring>
#define p 55
using namespace std;
int n;
int m,a[p][p],color[p][p];
int num,room=0,maxnum=0;
void dfs(int i,int j){
    color[i][j]=room;
    num++;
    if((a[i][j]&1)==0&&!color[i][j-1])//判断左边是否有墙及左边方块是否被访问过
        dfs(i,j-1);
    if((a[i][j]&2)==0&&!color[i-1][j])
        dfs(i-1,j);
    if((a[i][j]&4)==0&&!color[i][j+1])
        dfs(i,j+1);
    if((a[i][j]&8)==0&&!color[i+1][j])
        dfs(i+1,j);
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&a[i][j]);

        }
    }
    memset(color,0,sizeof(color));
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            if(!color[i][j]){
                num=0;
                room++;
                dfs(i,j);
                maxnum=max(num,maxnum);
            }
        }
    }
    printf("%d\n%d\n",room,maxnum);
}

猜你喜欢

转载自blog.csdn.net/lijunyan5/article/details/81742432