HDU 1155 Bungee Jumping(物理题,动能公式,弹性势能公式,重力势能公式)

传送门:

Bungee Jumping

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1718    Accepted Submission(s): 729


Problem Description
Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:
The rope is too short (or too strong), and James Bond will never reach the ground.
The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.
The rope's length and strength are good. James Bond touches the ground at a comfortable speed and can escape.
As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:
The force with which James is pulled towards the earth is
9.81 * w,
where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.
Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is
k * Δl,
where Δl is the difference between the rope's current length and its nominal, unexpanded length, and k is a rope-specific constant.
Given the rope's strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond's body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.

The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print "Stuck in the air.", "Killed by the impact.", or "James Bond survives.". Input is terminated by a line containing four 0s, this line should not be processed.
 
Sample Input
350 20 30 75 375 20 30 75 400 20 30 75 425 20 30 75 450 20 30 75 400 20 30 50 400 20 30 80 400 20 30 85 0 0 0 0
 
Sample Output
Killed by the impact. James Bond survives. James Bond survives. James Bond survives. Stuck in the air. Stuck in the air. James Bond survives. Killed by the impact.
 
Source
 
分析:
给你四个量k、l、s、w,其中k表示弹性绳的劲度系数,l 表示绳子自然状态的长度,s表示桥的高度,w表示James的体重;问题的背景是James要跳桥逃生,他用绳子一头系在桥上,绳子的另一头系在自己身上,他现在要跳下去(联想蹦极这一极限项目)。这样跳下去就会出现三种情况,第一种:绳子短于桥高与和劲度系数过大这两个因素的影响下使得人没办法接触地面,那么输出“被困在空中”;第二种:在各种因素的影响下,人到达地面的速度大于10米每秒,则输出“被撞击而死”,(这里不一定要求绳子很短,只要到达地面的速度达到要求,那他就。。。);第三种:到达地面的速度小于10米每秒,他就会割断绳子逃生,输出“这人幸存”。
理解:
这就是一题纯物理题,首先我们分析他从桥上直接跳下,则到达地面时的动能由动能定理得:e = w * g * s (以地面为参考系,重力势能转化为动能);
若这个绳子短于桥的高,那么在下落过程中,当下降高度小于绳子长时自由落体,当下降高度大于绳子长且小于桥高时变减速运动,现在我们把这个减速过程,弹性势能的增加量求出来,为:0.5 * (s-l)^2 * k;那么直接跳下的动能减去弹性势能的增加就是人到达地面的真实动能;若这个动能值为负则说明人没法到达地面,若这个值为正但通过这个值求出来的速度大于10,则很不幸;不大于10,很幸运!
 
总结:
告诉桥高s,人重w,g=9.81,绳子长l,劲度系数k.人从桥上调下。或拉着绳子下来,速度大于10就摔死。问秋后的情况。。
   (1)绳子l>=桥高s时,相当直接从桥上跳下,有mgs=1/2*mv^2
   (2)绳子l<桥高s时。。重力势能=动能+弹性势能=>mgs=1/2*mv^2+1/2k(s-l)^2
    <1>当弹性势能大于重力势能时,人在天上,<2>落地。。。
 
code:
 
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main()
{
    double k,l,s,w;
    while(~scanf("%lf %lf %lf %lf",&k,&l,&s,&w))
    {
        if(k==0&&l==0&&s==0&&w==0)
            break;
        if(l>=s)
        {
            double v=sqrt(2*9.81*s);
            if(v>10.0)
                cout<<"Killed by the impact."<<endl;
            else
                cout<<"James Bond survives."<<endl;
        }
        else
        {
            double fk=k*(s-l)*(s-l)/2.0;
            double fm=w*9.81*s;
            if(fk>fm)
                cout<<"Stuck in the air."<<endl;
            else
            {
                double v=sqrt((fm-fk)*2/w);
                if(v>10.0)
                    cout<<"Killed by the impact."<<endl;
                else
                    cout<<"James Bond survives."<<endl;
            }
        }
    }
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9326671.html