hdu 3507 Print Article(斜率优化dp)

Print Article

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 16378    Accepted Submission(s): 5042


Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤  500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
 
  
5 5 5 9 5 7 5
 

Sample Output
 
  
230
#include<bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn=500005;
ll a[maxn],sum[maxn],deq[maxn],dp[maxn];
ll n,m;
ll cal(ll j,ll i)
{
    return -2*sum[i]*sum[j]+sum[j]*sum[j]+dp[j]+m;
}
bool check(ll f1,ll f2,ll f3)
{
    ll a1=-2*sum[f1],b1=sum[f1]*sum[f1]+dp[f1]+m;
    ll a2=-2*sum[f2],b2=sum[f2]*sum[f2]+dp[f2]+m;
    ll a3=-2*sum[f3],b3=sum[f3]*sum[f3]+dp[f3]+m;
    return (a2-a1)*(b3-b2)>=(b2-b1)*(a3-a2);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            sum[i+1]=sum[i]+a[i];
        dp[0]=0;
        deq[0]=0;
        int s=0,t=1;
        for(int i=1;i<=n;i++)
        {
            while(s<t-1&&cal(deq[s],i)>=cal(deq[s+1],i))
                s++;
            dp[i]=sum[i]*sum[i]+cal(deq[s],i);
            while(s<t-1&&check(deq[t-2],deq[t-1],i))
                t--;
            deq[t++]=i;
        }
        printf("%lld\n",dp[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albertluf/article/details/81002838