素数表

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively. 
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

题解:构建两个函数,一个用来打表(素数);

一个用来将字符串储存的大数转换位 三位一个的整数;

再利用 同余定理 即可求解;

代码:

#include <iostream>
#include <cstring>
using namespace std;

int prime[1000010];
int t;

void sushu()
{
    int i,j;
    t=0;
    prime[t++]=2;
    for(i=3;i<1006666;i=i+2)
    {
        int f=1;
        for(j=0;prime[j]*prime[j]<=i;j++)
        {
            if(i%prime[j]==0)
            {
                f=0;
                break;
            }
        }
        if(f) prime[t++]=i;
    }
}//打素数表,用 t 记录共打了多少素数;

char s[150];
int qian[10005];
int w;

void convert()
{
    int i,j,len=strlen(s);
    memset(qian,0,sizeof(qian));
    int f=0;
    int b,c;//处理最前位数;
    b=0;
    c=len%3;
    for(i=0,j=0;i<len;i++)
    {
        qian[j]=qian[j]*10+s[i]-'0';
        f++;
        if(b==0 && f==c)
        {
            b=1;
            j++;
            f=0;
        }
        if(f==3)
        {
            j++;
            f=0;
        }
        w=j;
    }
} /*把字符串储存的大数,转化为每三位储存到一个数组,并用 W 储存共分成了多少个 三位数*/

int main()
{
    int n,i,j;
    sushu();
    while(cin>>s>>n && ( s[0]!='0' || n))
    {
        int sum,ans;
        convert();
        int f=0;
        for(i=0;i<t;i++)
        {
            if(prime[i]>=n)
                break;
            sum=0;
            ans=0;
            for(j=0;j<w;j++)
            {
                sum=(sum*1000+qian[j])%prime[i];
            }
            if(sum==0)
            {
                f=1;
                ans=prime[i];
                break;
            }
        }
        if(f) cout<<"BAD "<<ans<<endl;
        else cout<<"GOOD"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/h326301035/article/details/81217710