HDU 1506 Largest Rectangle in a Histogram(单调栈)

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22184    Accepted Submission(s): 6841


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
   
   
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
 

Sample Output
   
   
8
4000

题意:求最大矩形面积
h[]数组存高,合理的矩形左右边界满足;左:h[l]>=h[i];右:h[r]>=h[i]
L[i]和r[i]数组分别存当高度为h[i]时,往左满足h[j]>=h[i] 的最小的j,即从i点向左遍历的第一个高度比i小的点的右边一个点
往右满足h[j]>=h[i]的最大的j,即从i点向右遍历第一个高度比i小的点的左边一个点

面积S=max(h[i]*(r[i]-l[i]+1))
代码:**

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<set>
#include<stack>
using namespace std;
const int maxn = 100000+5;
long long h[maxn];
int n;
int l[maxn],r[maxn];
stack<int>S;
int main()
{

    while(scanf("%d",&n)){
        if(n==0) break;
        long long sum=0;
        for(int i=1;i<=n;i++)
            scanf("%lld",&h[i]);
        while(S.size()) S.pop();

        for(int i=1;i<=n;i++)
        {
            while(S.size()&&h[S.top()]>=h[i]) S.pop();
            if(S.empty()) l[i]=1;
            else l[i]=S.top()+1;
            S.push(i);
        }

        while(S.size()) S.pop();

        for(int i=n;i>=1;i--)
        {
            while(S.size()&&h[S.top()]>=h[i]) S.pop();

            if(S.empty()) r[i]=n;
            else r[i]=S.top()-1;
            S.push(i);

        }

        while(S.size()) S.pop();
        for(int i=1;i<=n;i++)
        {
            sum=max(sum,h[i]*(r[i]-l[i]+1));
        }
        printf("%lld\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hanyanwei123/article/details/81291908