HDU - 1506 Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题解:

输入N个宽度相等的长方形的高,从左到右依次排列,求其中最大的长方形面积;由每一个长方形向左右延申,找到最远的左右坐标相减即为这个能组成的最大长方形

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long mp[100010],l[100010],r[100010];//l[i]表示比a[i]大的数连续的最左边的位置,r表示右边
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int i,j;
        for(i=1; i<=n; i++)
            scanf("%lld",&mp[i]);
        l[1]=1,r[n]=n;
        for(i=2; i<=n; i++)//找出mp[i]左边连续大于自己的数的长度
        {
            int t=i;
            while(t>1&&mp[i]<=mp[t-1])
                t=l[t-1];
            l[i]=t;
        }
        for(i=n-1; i>=1; i--)//右边
        {
            int t=i;
            while(t<n&&mp[i]<=mp[t+1])
                t=r[t+1];
            r[i]=t;
        }
        long long maxx=0;
        for(i=1; i<=n; i++)
            if((r[i]-l[i]+1)*mp[i]>maxx)//最大面积
                maxx=(r[i]-l[i]+1)*mp[i];
        printf("%lld\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GJLfly/article/details/81434957