D - 4 HDU - 1506 Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

在这里插入图片描述

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000

问题链接:https://vjudge.net/contest/279630#problem/D

问题分析:
读取当前枚举矩形的左边跟右边小于当前矩形的长度。

AC代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
long long a[100001];
long long r[100001], l[100001];
int main()
{
	int  n;
	long long sum;
	while (cin >> n && n)
	{
		for (int i = 1; i <= n; i++)r[i] = l[i] = i;
		a[0] = a[n + 1] = -1;
		for (int i = 1; i <= n; i++)
			cin >> a[i];
		for (int j = 1; j <= n; j++)
				while (a[l[j] - 1] >= a[j])
					l[j] = l[l[j] - 1];
		for (int i = n; i >= 1; i--)
			while (a[r[i] + 1] >= a[i])
				r[i] = r[r[i] + 1];
		sum = 0;
		for (int i = 1; i <= n; i++)
		{
			if (sum < a[i] * (r[i] - l[i] + 1))
				sum = a[i] * (r[i] - l[i] + 1);
		}
		cout << sum << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43966523/article/details/86653051