Largest Rectangle in a Histogram 杭电1506

题目链接 :http://acm.hdu.edu.cn/showproblem.php?pid=1506

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000 0
 
Sample Output
8 4000
 题目大意:求最大的矩形面积;
题解:非递减单调栈,每次遇到一个小于栈内元素的值时,要出栈,出栈的同时记录面积,记录面积有点不太好理解....
面积的记录分为两种情况,我们假设当遇到元素arr[i]时,,arr[i]要大于栈顶元素。。。 我们取出栈顶元素x,然后再删除栈顶元素。若删除后栈为空,这说明从 从开始到 i ,取出 的元素是最小的,所以面积ans=arr[x]*(i-1)
若栈不为空,则说明从当前的栈顶元素的位置到 i,我们之前取出的arr[x]是最小的,即面积为ans=arr[x]*(i-st.top()-1)
(记得开long long)
AC code:
#include<bits/stdc++.h>
using namespace std;
const int N=1e5+7;
typedef long long ll;
ll arr[N];
int main(){
    int n;
    while(cin>>n,n){
        stack<int >st; 
        for(int i=1;i<=n;i++)    scanf("%lld",&arr[i]);
        arr[n+1]=0;
        long long ans=0;
        for(int i=1;i<=n+1;i++){
            if(st.empty()||arr[i]>=arr[st.top()]){
                st.push(i);
            }
            else {
                int x=st.top();
                while(st.size()&&arr[i]<arr[x]){
                    st.pop(); 
                    if(st.size()){
                        ans=max(ans,arr[x]*(i-st.top()-1));    
                        x=st.top();
                    }
                    else ans=max(ans,arr[x]*(i-1));
                }
                st.push(i);
            }
        }
        cout<<ans<<endl; 
    }
    
    
    
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Accepting/p/11602426.html
今日推荐