【PAT甲级】1040 Longest Symmetric String (25)(Manacher)

题目链接

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

思路:最长回文子串,用Manacher算法,分析见:Manacher 算法(求字符串的回文子串的最大长度)

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define DBGS() cout<<"START\n"
#define DBGE() cout<<"END\n"
const int N = 1e5+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;

int p[N];
char s[N],t[N];
int init() {
    int len=strlen(s);
    t[0]='$',t[1]='#';
    int j=2;
    for(int i=0; i<len; i++) {
        t[j++]=s[i];
        t[j++]='#';
    }
    s[j]='\0';
    return j;
}
void manacher() {
    int len=init();
    int maxlen=0,mx=0,id;
    for(int i=1; i<len; i++) {
        if(i<mx)
            p[i]=min(p[id*2-i],mx-i);
        else
            p[i]=1;
        while(t[i-p[i]]==t[i+p[i]])
            p[i]++;
        if(mx<i+p[i]) {
            id=i;
            mx=i+p[i];
        }
        maxlen=max(maxlen,p[i]-1);
    }
    printf("%d\n",maxlen);
}
int main() {
    fgets(s,sizeof(s),stdin);
    manacher();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81275321