【笨方法学PAT】1040 Longest Symmetric String (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84872560

一、题目

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

二、题目大意

最大回文子序列。

三、考点

遍历

四、注意

1、暴力求解N^2复杂度,估计会超时;

2、引入out_length维护最长长度,减小计算复杂度;

3、注意substr()的用法:substr(i,j),从i开始的j个数字。

五、代码

#include<iostream>
#include<string>
using namespace std;

int out_length = 0;

bool judgeSym(string s) {
	for (int i = 0; i < s.length() / 2; ++i) {
		if (s[i] != s[s.length() - 1 - i])
			return false;
	}
	return true;
}

int main() {
	//read
	string s;
	getline(cin, s);

	//solve
	for (int i = 0; i < s.length(); ++i) {
		for (int j = i + out_length ; j < s.length(); ++j) {
			string t = s.substr(i, j - i + 1);
			//cout <<out_length<<" "<< t << endl;
			if (judgeSym(t) == true) {
				if (j - i + 1> out_length) {
					out_length = j - i + 1;
				}
			}
		}
	}

	//output
	cout << out_length << endl;

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84872560