PAT-A 1062. Talent and Virtue (25)(25 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805410555346944

1062 Talent and Virtue (25)(25 分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=10^5^), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
 
struct Student{
	char id[10]; //准考证号 
    int de;    // 德分 
	int cai;   // 才分 
	int sum;   //总分 
	int flag;  //类别,对应5类	
}stu[100010];
 
//自定义cmp算子,用sort排序 
bool cmp(Student a,Student b){
	if(a.flag!=b.flag){//类别小的在前 
		return a.flag<b.flag; 
	}
	else if(a.sum!=b.sum){//类别相同,总分大的在前 
		return a.sum>b.sum; 
	}
	else if(a.de!=b.de){//总分相同,德分高在前 
		return a.de>b.de;
	} 
	else{//德分相同时,准考证号小的在前 
		return strcmp(a.id,b.id)<0;//a.id<b.id; 
	}
}
int main(int argc, char** argv) {
	int n,L,H;
	cin>>n>>L>>H;
	int cnt=0;//不及格人数 
	int m=n;
	for(int i=0;i<n;i++){
	    scanf("%s %d %d",&stu[i].id,&stu[i].de,&stu[i].cai);
		stu[i].sum=stu[i].de+stu[i].cai; 
	    if(stu[i].de<L||stu[i].cai<L){
	    	stu[i].flag=5;
   		    cnt++;
   		    m--;
		}
		else if(stu[i].de>=H&&stu[i].cai>=H){
	   	    stu[i].flag=1;
	    }
	    else if(stu[i].de>=H&&stu[i].cai<H){
	    	stu[i].flag=2;
		}
		else if(stu[i].de>=stu[i].cai){
			stu[i].flag=3;
		}
		else{
			stu[i].flag=4;
		}
	} 
	sort(stu,stu+n,cmp);
	//int m=n-cnt;//及格人数;
	printf("%d\n",m);
	for(int i=0;i<m;i++){
		printf("%s %d %d\n",stu[i].id,stu[i].de,stu[i].cai);
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81387283