PAT A1062 Talent and Virtue (25分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105​​ ), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

题意:

输入总人数N、及格分L、达标分H,考生的编号,品德得分(德分),才能得分(才分);排除至少有一项不及格的考生,按照圣人、君子、愚人、小人的优先级依次排序输出其编号、德分、才分。排序的比较依据为总分降序、德分降序、编号升序.

思路:

(1)开设结构体数组a存放所有考生的编号、德分、才分,开设结构体数组b作为临时数组依次存放圣人、君子、愚人、小人的编号、德分、才分并排序后输出;
(2)圣人的德分、才分要求均高于H,君子的德分高于H、才分大于等于L小于H,愚人的德分、才分均大于等于L小于H并且德分大于等于才分,小人的德分大于等于L小于H、才分大于等于L并且德分小于才分.

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct people{
	int id,virtue,talent;
}a[100010],b[100010];
bool cmp(people a,people b){
	if((a.virtue+a.talent)!=(b.virtue+b.talent))
		return (a.virtue+a.talent)>(b.virtue+b.talent);
	else if(a.virtue!=b.virtue)
		return a.virtue>b.virtue;
	else 
		return a.id<b.id;
}

int main(){
	int N,L,H;
	scanf("%d %d %d",&N,&L,&H);
	for(int i=0;i<N;i++){
		scanf("%d %d %d",&a[i].id,&a[i].virtue,&a[i].talent);	
	}
	int M = 0;
	for(int i=0;i<N;i++){
		if(a[i].talent>=L&&a[i].virtue>=L)
			M++;
	}
	printf("%d\n",M);
	int k = 0;//记录临时数组b中包含的考生人数 
	for(int i=0;i<N;i++){//圣人 
		if(a[i].virtue>=H&&a[i].talent>=H){
			b[k++] = a[i]; 
		}
	}
	sort(b,b+k,cmp);
	for(int i=0;i<k;i++){
		printf("%d %d %d\n",b[i].id,b[i].virtue,b[i].talent);
	}
	k = 0;
	for(int i=0;i<N;i++){//君子 
		if(a[i].virtue>=H&&a[i].talent>=L&&a[i].talent<H){
			b[k++] = a[i]; 
		}
	}
	sort(b,b+k,cmp);
	for(int i=0;i<k;i++){
		printf("%d %d %d\n",b[i].id,b[i].virtue,b[i].talent);
	}
	k = 0;
	for(int i=0;i<N;i++){//愚人 
		if(a[i].virtue>=L&&a[i].virtue<H&&a[i].talent>=L&&a[i].talent<H&&a[i].virtue>=a[i].talent){
			b[k++] = a[i]; 
		}
	}
	sort(b,b+k,cmp);
	for(int i=0;i<k;i++){
		printf("%d %d %d\n",b[i].id,b[i].virtue,b[i].talent);
	}
	k = 0;
	for(int i=0;i<N;i++){//小人 
		if(a[i].virtue>=L&&a[i].virtue<H&&a[i].talent>=L&&a[i].virtue<a[i].talent){
			b[k++] = a[i]; 
		}
	}
	sort(b,b+k,cmp);
	for(int i=0;i<k;i++){
		printf("%d %d %d\n",b[i].id,b[i].virtue,b[i].talent);
	}	
}

词汇:

outweight 重于
qualified 合格的
qualification 资格,达标
tie 平局
with respect to 依据

发布了26 篇原创文章 · 获赞 0 · 访问量 472

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/104056488