PAT (Advanced Level) Practice A1062 Talent and Virtue (25 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86363259

1062 Talent and Virtue (25 分)
About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10
​5
​​ ), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade
where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

//本题即为B1015的英文版
//https://blog.csdn.net/m0_37454852/article/details/85456282

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct Student
{
    int ID;
    int Virtue;
    int Talent;
    int Total;//德分和才分累加和
    int category;//用来区分该学生属于哪一类别
}Student;

Student S[100010] = {0};//结构体数组来存储

bool cmp(Student A, Student B)
{
    if(A.Total != B.Total) return A.Total > B.Total;//>为逆序排序,<为顺序排序
    if(A.Virtue != B.Virtue) return A.Virtue > B.Virtue;
    return A.ID < B.ID;//ID不会出现相等情况
}

int main()
{
    int N = 0, L = 0, H = 0;
    int cnt = 0;
    scanf("%d %d %d", &N, &L, &H);
    for(int i = 0; i<N; i++)
    {
        scanf("%d %d %d", &S[cnt].ID, &S[cnt].Virtue, &S[cnt].Talent);
        if(S[cnt].Virtue < L || S[cnt].Talent < L ) continue;//不合格者,进入下一次,不计数
        else if(S[cnt].Virtue >= H && S[cnt].Talent >= H) S[cnt].category = 1;//区分类别
        else if(S[cnt].Virtue >= H) S[cnt].category = 2;
        else if(S[cnt].Virtue < H && S[cnt].Talent < H && S[cnt].Virtue >= S[cnt].Talent) S[cnt].category = 3;
        else S[cnt].category = 4;
        S[cnt].Total = S[cnt].Virtue + S[cnt].Talent;//计算累计和
        cnt++;//计数
    }
    sort(S, S+cnt, cmp);//排序后按类别输出即可
    printf("%d\n", cnt);
    for(int i = 1; i<5; i++)
    {
        for(int j=0; j<cnt; j++)
        {
            if(S[j].category == i)
            {
                printf("%d %d %d\n", S[j].ID, S[j].Virtue, S[j].Talent);
            }
        }
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86363259