D - Daydreaming Stockbroker(模拟)

Gina Reed, the famous stockbroker, is having a slow day at work, and between rounds of solitaire she is daydreaming. Foretelling the future is hard, but imagine if you could just go back in time and use your knowledge of stock price history in order to maximize your profits!

Now Gina starts to wonder: if she were to go back in time a few days and bring a measly $100 with her, how much money could she make by just buying and selling stock in Rollercoaster Inc. (the most volatile stock in existence) at the right times? Would she earn enough to retire comfortably in a mansion on Tenerife?

Photo by liz west on flickr

Note that Gina can not buy fractional shares, she must buy whole shares in Rollercoaster Inc. The total number of shares in Rollercoaster Inc. is 100 000, so Gina can not own more than 100 000 shares at any time. In Gina’s daydream, the world is nice and simple: there are no fees for buying and selling stocks, stock prices change only once per day, and her trading does not influence the valuation of the stock.

Input

The first line of input contains an integer d (1 ≤ d ≤ 365), the number of days that Gina goes back in time in her daydream. Then follow d lines, the i’th of which contains an integer pi (1 ≤ pi ≤ 500) giving the price at which Gina can buy or sell stock in Rollercoaster Inc. on day i. Days are ordered from oldest to newest.

Output

Output the maximum possible amount of money Gina can have on the last day. Note that the answer may exceed 232.

Sample Input

6
100
200
100
150
125
300

Sample Output

650

【解析】

题意:如果你能穿越回过去,在知道股价的时候如何赚最多的钱!穿越回n天前,每天的股价给出。开始只有100美元,且总共就10W股。

模拟题,虽然有点麻烦。总体思想就是高价卖出,低价买入。

#include<iostream>
using namespace std;
int main()
{
	long long d;
	while (~scanf("%lld",&d))
	{
		long long pri, res = 100, have = 0, now = 100;
		for (long long i = 0; i<d; i++)
		{
			scanf("%lld", &pri);
			if (pri <= now)//低价
			{
				have = res / pri;
				now = pri;
			}
			if (have>100000) have = 100000;//题意总共就10W股
			if (pri>now)//高价
			{
				res += have * pri - now * have;
				now = pri;
			}
		}
		printf("%lld\n", res);
	}
}

猜你喜欢

转载自blog.csdn.net/waterboy_cj/article/details/81541490
今日推荐