Daydreaming Stockbroker(贪心)

Description

Gina Reed, the famous stockbroker, is having a slow day at work, and between rounds of solitaire she is daydreaming. Foretelling the future is hard, but imagine if you could just go back in time and use your knowledge of stock price history in order to maximize your profits!

Now Gina starts to wonder: if she were to go back in time a few days and bring a measly $100 with her, how much money could she make by just buying and selling stock in Rollercoaster Inc. (the most volatile stock in existence) at the right times? Would she earn enough to retire comfortably in a mansion on Tenerife?

Note that Gina can not buy fractional shares, she must buy whole shares in Rollercoaster Inc. The total number of shares in Rollercoaster Inc. is 100 000, so Gina can not own more than 100 000 shares at any time. In Gina’s daydream, the world is nice and simple: there are no fees for buying and selling stocks, stock prices change only once per day, and her trading does not influence the valuation of the stock.

Input

The first line of input contains an integer d (1 ≤ d ≤ 365), the number of days that Gina goes back in time in her daydream. Then follow d lines, the i’th of which contains an integer pi (1 ≤ pi ≤ 500) giving the price at which Gina can buy or sell stock in Rollercoaster Inc. on day i. Days are ordered from oldest to newest.

Output

Output the maximum possible amount of money Gina can have on the last day. Note that the answer may exceed 232.

Sample Input

6
100
200
100
150
125
300

Sample Output

650

解析

  题意是给100美金的初始资金,再给出d天每天的股票每股的价格,你可以选择买进股票或卖出手中的股票,限制是手中持有的股票不能超过100000股,让你求d天后能获得的最大利润。

  在股票价格低的时候买进,价格高的的时候卖出。

代码

#include<stdio.h>
#include<string.h>
typedef long long LL;
int main()
{
    int days,i,p[600];
    while(~scanf("%d",&days))
    {
        for(i=1;i<=days;i++)
        {
            scanf("%d",&p[i]);
        }
        int mark[600];
        p[days+1]=-1; p[0]=1000;
        for(i=0;i<=days;i++) //标记第i天是该买进还是卖出
        {
            if(p[i+1]>=p[i]) 
                mark[i]=1;
            else if(p[i+1]<p[i])
                mark[i]=-1;
        }
        LL money=100,stock=0; //stock为当前手中持有的股票
        for(i=1;i<=days;i++)
        {
            if(mark[i]==1&&mark[i-1]==-1)
            {
                if(money>=p[i])
                {
                    LL temp=money/p[i];
                    if(temp>=1e5)
                        temp=1e5;
                    stock=temp;
                    money-=p[i]*temp;
                }
            }
            else if(mark[i]==-1&&mark[i-1]==1)
            {
                  money+=p[i]*stock;
                  stock=0;
            }
        }
        printf("%lld\n",money);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/81541773
今日推荐