暑假提高4-D - Daydreaming Stockbroker(模拟&&题意理解)

Gina Reed, the famous stockbroker, is having a slow day at work, and between rounds of solitaire she is daydreaming. Foretelling the future is hard, but imagine if you could just go back in time and use your knowledge of stock price history in order to maximize your profits!

Now Gina starts to wonder: if she were to go back in time a few days and bring a measly $100 with her, how much money could she make by just buying and selling stock in Rollercoaster Inc. (the most volatile stock in existence) at the right times? Would she earn enough to retire comfortably in a mansion on Tenerife?

Photo by liz west on flickr

Note that Gina can not buy fractional shares, she must buy whole shares in Rollercoaster Inc. The total number of shares in Rollercoaster Inc. is 100 000, so Gina can not own more than 100 000 shares at any time. In Gina’s daydream, the world is nice and simple: there are no fees for buying and selling stocks, stock prices change only once per day, and her trading does not influence the valuation of the stock.

Input

The first line of input contains an integer d (1 ≤ d ≤ 365), the number of days that Gina goes back in time in her daydream. Then follow d lines, the i’th of which contains an integer pi (1 ≤ pi ≤ 500) giving the price at which Gina can buy or sell stock in Rollercoaster Inc. on day i. Days are ordered from oldest to newest.

Output

Output the maximum possible amount of money Gina can have on the last day. Note that the answer may exceed 232.

Sample Input

6
100
200
100
150
125
300

Sample Output

650

【分析】先把题意理解清楚!!然后就是低价收入高价卖出,价格不断变化。如果大于10000股,再重新赋值为10000;就是注意题意的理解吧,懂了就好做了;

#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
	int days;
	long long money,all,stock=0,q;
	while(~scanf("%d",&days))
	{
		all=100;
		stock=0;
		q=100;
		for(int i=0;i<days;i++)
		{
			scanf("%lld",&money);
			if(money<=q)
			{
				if(stock>100000)stock=100000;
				stock=all/money;
				q=money;
			}
			else if(money>q)
			{
				if(stock>100000)stock=100000;
				all+=stock*(money-q);
				q=money;
			}
			
		}
		cout<<all<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/81541527
今日推荐