CSUOJ 2026: Daydreaming Stockbroker

2026: Daydreaming Stockbroker

Description

Gina Reed, the famous stockbroker, is having a slow day at work, and between rounds of solitaire she is daydreaming. Foretelling the future is hard, but imagine if you could just go back in time and use your knowledge of stock price history in order to maximize your profits!

Now Gina starts to wonder: if she were to go back in time a few days and bring a measly $100 with her, how much money could she make by just buying and selling stock in Rollercoaster Inc. (the most volatile stock in existence) at the right times? Would she earn enough to retire comfortably in a mansion on Tenerife?

Note that Gina can not buy fractional shares, she must buy whole shares in Rollercoaster Inc. The total number of shares in Rollercoaster Inc. is 100 000, so Gina can not own more than 100 000 shares at any time. In Gina’s daydream, the world is nice and simple: there are no fees for buying and selling stocks, stock prices change only once per day, and her trading does not influence the valuation of the stock.

Input

The first line of input contains an integer d (1 ≤ d ≤ 365), the number of days that Gina goes back in time in her daydream. Then follow d lines, the i’th of which contains an integer pi (1 ≤ pi ≤ 500) giving the price at which Gina can buy or sell stock in Rollercoaster Inc. on day i. Days are ordered from oldest to newest.

Output

Output the maximum possible amount of money Gina can have on the last day. Note that the answer may exceed 232.

Sample Input

6
100
200
100
150
125
300

Sample Output

650

Hint

乍一看好像有点复杂,看题目的意思也没搞懂一天究竟只能买或卖一次还是既可以买又可以卖,不过不要紧,其实只要后一天比前一天价高就可以出手了,如果持续走高也没关系,买完再卖再买效果是一样的。
思路是有了代码也很快写出来了但是就是不停地WA,1点钟在电脑前怀疑人生。。。一直以为是思路的问题,但我反复考量就是不知道问题在哪。第二天中午再一看,得,我money和存储股票价格的数组都开了long long int,但是number还是int,当然有可能溢出啦。再一试,终于A了。可能这就是菜吧orz。。。。
心酸的提交记录

#include<stdio.h>
#define MAX 100000
int d;
long long int p[400];
long long int money;
long long int number;
int main()
{
  while (scanf("%d", &d) != EOF)
  {
  	money = 100;
  	for (int i = 0; i < d; i++)
  	{
  		scanf("%lld", &p[i]);
  	}
  	for (int i = 0; i < d-1; i++)
  	{
  		if (p[i]<p[i+1])
  		{
  			number = money / p[i];
  			if (number > MAX)
  				number = MAX;
  			money = money + number * (p[i + 1] - p[i]);
  		}
  	}
  	printf("%lld\n", money);
  }
}

猜你喜欢

转载自blog.csdn.net/irontonystark/article/details/85260221
今日推荐