HDU 1003 Max Sum 求区间最大值 (尺取法)

            Max Sum

          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
            Total Submission(s): 294096    Accepted Submission(s): 69830


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int num[100086];
int main()
{
    int T;
    scanf("%d",&T);
    int cases=0;
    while(T--){
        cases++;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&num[i]);
        }
        int l=1,r=1;
        int x,y;
        int maxx=-999999999,sum=0;
        for(int i=1;i<=n;i++){
            sum+=num[i];
            if(sum>maxx){
                x=l;y=i;
                maxx=sum;
            }
            if(sum<0){sum=0;l=i+1;}
        }
        if(cases!=1){printf("\n");}
        printf("Case %d:\n",cases);
        printf("%d %d %d\n",maxx,x,y);
    }
}

  

猜你喜欢

转载自www.cnblogs.com/ZGQblogs/p/9489907.html