【PAT】A1051. Pop Sequence (25)

Description:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2


Sample Output:
YES
NO
NO
YES
NO

//NKW 甲级真题1040
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <stack>
using namespace std;
stack<int> st;
vector<int> vi;
bool check(int m, int n){
	while (!st.empty())	st.pop();
	int cnt = 0;
	for (int i = 1; i <= n; i++){
		st.push(i);
		if (st.size() > m)		return false;
		while (st.size() && st.top() == vi[cnt]){
			st.pop();
			cnt++;
		}
	}
	if (cnt < n)	return false;
	else	return true;
}
int main(){
	int m, n, k, num;
	scanf("%d %d %d", &m, &n, &k);
	for (int i = 0; i < k; i++){
		for (int j = 0; j < n; j++){
			scanf("%d", &num);
			vi.push_back(num);
		}
		if (check(m, n))	printf("YES\n");
		else	printf("NO\n");
		vi.clear();
	}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81264723