【PAT甲级】1051 Pop Sequence (25)

题目链接

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路:栈 模拟

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <sstream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e3+5;

int a[N];
stack<int>st;
int main() {
    int m,n,k;
    cin>>m>>n>>k;
    while(k--) {
        for(int i=0; i<n; i++) {
            cin>>a[i];
        }
        while(!st.empty()) {
            st.pop();
        }
        bool flag=0;
        int cur=0;
        rep(i,1,n+1) {
            st.push(i);
            cout<<st.size()<<endl;
            if(st.size()>m) {
                flag=1;
                break;
            }
            while(!st.empty()&&st.top()==a[cur]) {
                st.pop();
                cur++;
            }
        }
        cout<<(!flag&&st.empty()?"YES":"NO")<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81349002