PAT甲级-1051 Pop Sequence(25 分)【栈模拟删除操作】

1051 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

解题思路: 这题就是模拟,今天懒得打字了

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
	int m,n,k;
	scanf("%d%d%d",&m,&n,&k);
	for(int j=0;j<k;j++)
	{
		bool flag=false;
		stack<int>ps;
		vector<int>v(n+1);
		for(int i=1;i<=n;i++)
		scanf("%d",&v[i]);
		int c=1;
		for(int i=1;i<=n;i++)
		{
			ps.push(i);
			if(ps.size()>m) break;
			while(!ps.empty()&&ps.top()==v[c])
			{
				ps.pop();
				c++;
		    }
		}
		if(c==n+1) flag=true;
		printf("%s\n",flag?"YES":"NO");
	
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82318934