【笨方法学PAT】1051 Pop Sequence (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84893963

一、题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

二、题目大意

有个容量限制为m的栈,分别把1,2,3,…,n入栈,给出一个系列出栈顺序,问这些出栈顺序是否可能。

三、考点

四、注意

1、注意以进栈顺序为主循环;

2、参考:https://www.liuchuo.net/archives/2232

五、代码

#include<iostream>
#include<stack>
#include<vector>
using namespace std;
int main() {
	//read
	int m, n, k;
	cin >> m >> n >> k;

	//solve
	while (k--) {
		bool flag = true;
		int num = 1;
		stack<int> sta;
		vector<int> vec(n+1);

		for (int i = 1; i <= n; ++i) {
			cin >> vec[i];
		}

		for (int i = 1; i <= n; ++i) {
			sta.push(i);
			if (sta.size() > m) {
				break;
			}
			while (!sta.empty() && sta.top() == vec[num]) {
				sta.pop();
				num++;
			}
		}

		//output
		if (num != n+1)
			cout << "NO" << endl;
		else
			cout << "YES" << endl;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84893963