(PAT甲级)1051. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <iostream>
#include <stack>
using namespace std;

int main()
{
	int M, N, K;
	cin >> M >> N >> K;
	int *Arr = new int[N+1];        //存放待判断序列
	for (int i = 0; i < K; i++)     //要判断序列个数
	{
		stack<int> s;               //堆栈s
		int count = 0;              //用于判断序列中的每一个数是否都能从堆栈中pop出来
		for (int j = 1; j <= N; j++)//输入一个判断序列中的数
			cin >> Arr[j];
		for (int j = 1; j <= N; j++)//将123456按顺序push到堆栈中
		{
			s.push(j);
			if (s.size()> M) break;//堆栈存不下了,说明判断数列中的数和堆栈栈顶都不相等,那么这个数列肯定不存在
			while (!s.empty()&&(s.top() == Arr[count + 1]))//当堆栈不为空而且数列的元素和栈顶元素一样的时候,就要继续往下判断了
			{
				s.pop();
				count++;
			}
		}

		if (count == N) cout << "YES"<<endl;//当所有的数都pop出来的时候,count的数目应该和数列中的数一致
		else cout << "NO" << endl;
	}
	delete[]Arr;
	return 0;
}


猜你喜欢

转载自blog.csdn.net/yuquan87/article/details/80279711