【PAT】A1060. Are They Equal (25)

Description:
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9


Sample Output 1:
YES 0.123*10^5


Sample Input 2:
3 120 128


Sample Output 2:
NO 0.120*10^3 0.128*10^3

//NKW 甲级真题1020
#pragma warning(disable:4996)
#include <iostream>
#include <stdlib.h>
#include <string>
using namespace std;
int n, ea = 0, eb = 0;
string sa, sb;
string deal(string s, int &e){
	while (s.length() && s[0] == '0')
		s.erase(s.begin());
	if (s[0] == '.'){
		s.erase(s.begin());
		while (s.length() && s[0] == '0'){
			s.erase(s.begin());
			e--;
		}
	}
	else{
		for (int i = 0; i < s.length(); i++){
			if (s[i] == '.'){
				s.erase(s.begin() + i);
				e = i;
				break;
			}
		}
		if (e == 0)
			e = s.length();
	}
	while (s.length() < n)
		s += '0';
	return s.substr(0, n);
}
int main(){
	cin >> n >> sa >> sb;
	sa = deal(sa, ea);
	sb = deal(sb, eb);
	if (sa == sb)
		cout << "YES 0." << sa << "*10^" << ea << endl;
	else
		cout << "NO 0." << sa << "*10^" << ea << " 0." << sb << "*10^" << eb << endl;
	system("pause");
	return 0;
}

程序分析:

本题需要删除前置零。测试点有0000XX的输入。

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81192119