1060 Are They Equal(25 分)(cj)

1060 Are They Equal(25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

推荐 https://blog.csdn.net/jmlikun/article/details/50074427  有详细的测试数据。

思路,暴力题 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
using namespace std;
class res {
public:
	string s;
	int size=0;
};
res deal(string x);
int main(){
	int n;
	string a, b;
	cin >> n >> a >> b;
	res res_a, res_b;
	res_a = deal(a);
	res_b = deal(b);
	if (res_a.size == res_b.size) {
		bool f = 1;
		while (res_a.s.size() < n) res_a.s += '0';
		while (res_b.s.size() < n) res_b.s += '0';
		for (int i = 0; i < n; ++i) {
			if (res_a.s[i] != res_b.s[i]) {
				cout << "NO ";
				cout << "0." << (res_a.s.substr(0, n)) << "*10^" << res_a.size << ' ';
				cout << "0." << (res_b.s.substr(0, n)) << "*10^" << res_b.size;
				f = 0;
				break;
			}
		}
		if (f) {
			cout << "YES ";
			cout << "0." << (res_a.s.substr(0, n)) << "*10^" << res_a.size;
		}
	}
	else {
		cout << "NO ";
		cout << "0." << (res_a.s.substr(0, n)) << "*10^" << res_a.size << ' ';
		cout << "0." << (res_b.s.substr(0, n)) << "*10^" << res_b.size;
	}
	system("pause");
	return 0;
}
res deal(string x) {
	int f = 1;
	res r;
	for (int i = 0; i < x.size(); ++i) {
		if (x[i] != '.') {
			r.s += x[i];
			if(f) r.size++;
		}
		else f = 0;
	}
	bool ff = 1;
	for (int i = 0; i < r.s.size(); ++i) {
		if (r.s[i] != '0') {
			ff = 0;
			break;
		}
	}
	if (ff) {
		r.s = "0";
		r.size = 0;
	}
	else {
		int p = 0;
		while (r.s[p] == '0') {
			if (p == r.s.size() - 1) break;
			r.size--;
			p++;
		}
		r.s = r.s.substr(p);
	}
	
	return r;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82082586