6.3 PAT A1060 Are They Equal (25分)(利用string处理科学计数法)

1060 Are They Equal (25分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

主要步骤为:

1、去除前导0;

2、去除小数点,注意纯小数和非纯小数的处理方法

3、去除纯小数后的0

4、记录指数e

5、获取答案。

参考代码:

#include<iostream>
#include <string>
using namespace std;
int n;
string deal(string s, int & e)
{
	int k=0; //s的下标 
	while(s.length()>0&& s[0]=='0') //去掉s的前导0;
	{
		s.erase(s.begin()); 
	}
	if(s[0]=='.') //若去掉前导0后是小数点,说明s是小于1的小数。
	{
		s.erase(s.begin()); //去掉小数点!
		while(s.length()>0 && s[0]=='0')
		{
			s.erase(s.begin()); //	去掉小数点后非零位前的所有0.
			e--;//每去掉一个0,指数e减一
		}		
	}
	else //若前导去掉后不是小数点,则找到后面的小数点删除!
	{
		while(k<s.length()&& s[k]!='.') //寻找小数点
		{
			k++;
			e++;
		}
		if(k<s.length())
			s.erase(s.begin()+k); //把小数点删除 
	}
	if(s.length() == 0) //如果去除前导0后s的长度变为0,则说明这个数是0; 
		e=0; 
	int num=0;
	k=0;
	string ans="";
	while(num<n) //只要精度还没有到n 
	{
		if(k<s.length()) //只要还有数字,就加到res末尾 
			ans+=s[k++];
		else 
			ans+="0";//否则res末尾+0;
		num++; //精度+ 1 
	}
	return ans;  
}

int main()
{
	string s1,s2;
	string s3,s4;
	while(cin>>n>>s1>>s2)
	{
		int e1=0,e2=0;
		s3=deal(s1,e1);
		s4=deal(s2,e2);
		if(s3==s4&&e1==e2)
			cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
		else
			cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43590614/article/details/105345533
今日推荐