6.3 string的常见用法详解:A1060 Are They Equal

A1060 Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

#include <cstdio>
#include <stdlib.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;

int n;
string deal(string s,int& e){
    int k=0;
    while(s.length()>0 && s[0]=='0'){
        s.erase(s.begin());//去掉s的前导零
    }
    if(s[0]=='.'){//小于1的数
        s.erase(s.begin());
        while(s.length()>0 && s[0]=='0'){
            s.erase(s.begin());//去掉小数点后非零位前的所有零
            e--;//每去掉一个0,指数e减1
        }
    }
    else{//大于1的数
        while(k<s.length() && s[k]!='.'){
            k++;
            e++;
        }
        if(k<s.length())//把小数点删除
            s.erase(s.begin()+k);
    }
    if(s.length()==0)
        e=0;//如果去除前导零后s的长度变为0,则说明这个数是0
    int num=0;
    k=0;
    string res;
    while(num<n){//精度不到n
        if(k<s.length()) res+=s[k++];
        else res+='0';
        num++;
    }
    return res;
}
int main(){
    string s1,s2,s3,s4;
    cin>>n>>s1>>s2;
    int e1=0,e2=0;
    s3=deal(s1,e1);
    s4=deal(s2,e2);
    if(s3==s4 && e1==e2)
        cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
    else
        cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
    return 0;
}
发布了157 篇原创文章 · 获赞 15 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/nanke_4869/article/details/104755096
今日推荐