PAT A1060 Are They Equal+字符串处理

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

代码如下:

#include <iostream>
#include <string>

using namespace std;

int n;

string convert2std(string s,int &e){
    int k=0; //s的下标
    //清除前导0
    while(s.size()>0 && s[0]=='0'){
        s.erase(s.begin());
    }

    //去除小数点和小数点后的0
    if(s[0]=='.'){
        s.erase(s.begin());
        while(s.size()>0 && s[0]=='0'){
            s.erase(s.begin());
            e--; //小数点后有几个0就是负指数几
        }
    }else{
        for(;k<s.size();k++){
            if(s[k]=='.'){ //去除小数点
                s.erase(s.begin()+k);
                break;
            }
            else
                e++;
        }
    }
    //这样留下来不是0的字符串了 即a1a2a3a4...
    if(s.size()==0){
        e=0;
    }
    string ans;
    if(n<=s.size()){
        ans=s.substr(0,n);
    }else{
        ans=s;
        for(int i=0;i<n-s.size();i++){
            ans+='0';
        }
    }
    return ans;


}
int main()
{
    string num1,num2;
    cin >> n >> num1 >> num2;
    int e1=0,e2=0;
    string s1=convert2std(num1,e1);
    string s2=convert2std(num2,e2);
    if(s1==s2 && e1==e2){
        cout << "YES 0." << s1 << "*10^" << e1 << endl;
    }else{
        cout << "NO 0." << s1 << "*10^" << e1 << " 0."  << s2 << "*10^" << e2 << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/88370853
今日推荐