PAT A1060号题 Are TheyEqual

题目描述:
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
输入格式:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.
Output Specification:
输出格式
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
输入样例 1
3 12300 12358.9
输出样例 1
YES 0.123
10^5
这道题的意思就是:
给出两个数,问:将他们写成保留N位小数的科学计数法后是否相等。如果相等,则输出YES,并且给出转换结果;如果不相等,则输出NO,并分别给出两个数的转换结果。

#include<iostream>
#include<string>
int n;		//有效的位数
string deal(string s, int& e){
	int k = 0;
	while(s.length() > 0 && s[0] == '0'){
		s.erase(s.begin());
	}
	if(s[0] == '.'){
		s.erase(s.begin());
		while(s.length() > 0 && s[0] == '0'){
			s.erase(s.begin());
			e--;			//每去掉一个0,指数e减1
		}
	}else{					//去掉前导零后不是小数点,则找到后面的小鼠嗲删除
		while(k < s.length() && s[k] != '.'){//寻找小数点
			k++;
			e++;		//只要不喷到小数点就让指数e++
		}
	if(k < s.length()){
		s.erase(s.begin() + k)   //把小数点删除
		}	
	}
	if(s.length() == 0){
		e = 0;		如果去除前导零后s的长度变为0,说明这个是0
	}
	int num = 0;
	k = 0;
	string res;
	while(num < n){
		if(k < s.length()) res += s[k++];	//只要还有数字,就加到res末尾
		else res += '0';
		num++;
	}
	return res;
}
int main(){
	string s1,s2,s3,s4;
	cin >> n >> s1 >> s2;
	int e1 = 0,e2 = 0;		//e1,e2为s1与s2的指数
	s3 = deal(s1, e1);
	s4 = deal(s2, e2);
	if(s3 == s4 && e1 == e2){		//主体相同且指数相同则YES
		cout<<"YES 0."<<s3<<"*10"<<e1<<endl;
	}
	else{
		cout<<"NO 0."<<s3<<"*10"<<e1<<" 0."<<s4<<"*10"<<e2<<endl;	
	}
	return 0;
}
发布了19 篇原创文章 · 获赞 2 · 访问量 736

猜你喜欢

转载自blog.csdn.net/zan1763921822/article/details/105439210
今日推荐