PAT 1055 The World's Richest[排序][如何不超时]

1055 The World's Richest(25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (105​​) - the total number of people, and K (103​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [106​​,106​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the Mrichest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

 题目大意:给出名字,年龄,财富,并且输入几个以年龄为区间的查询,输出这个年龄段内的规定人数,并且需要按财富非递增排,财富相同按年龄非递减排,年龄相同,那么根据名字字典序有效到大排。

//这是我第一次提交的代码,将其选出来重新排序的粗暴方法,第2个测试点没有过,显示超时,得了22分。

#include <stdio.h>
#include<algorithm>
#include <iostream>
#include<vector>
#include<string.h>
using namespace std;
struct Stu{
    char name[10];
    int age,worth;
}stu[100000];

bool cmp(Stu &a,Stu &b){
    if(a.worth>b.worth)return true;
    else if(a.worth==b.worth&&a.age<b.age)
        return true;
    else if(a.worth==b.worth&&a.age==b.age&&strcmp(a.name,b.name)<0)
        return true;
    return false;
}
bool cmp2(Stu &a,Stu &b){
    if(a.age<b.age)return true;
    else if(a.age==b.age&&a.worth>b.worth)return true;
    else if(a.age==b.age&&a.worth==b.worth&&strcmp(a.name,b.name)<0)return true;
    return false;
}
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    for(int i=0;i<n;i++){
        scanf("%s %d %d",stu[i].name,&stu[i].age,&stu[i].worth);
    }
    sort(stu,stu+n,cmp2);//一开始应该先按年龄排序~
    int no,from,to;
    for(int i=0;i<k;i++){
        vector<Stu> sv;
        scanf("%d %d %d",&no,&from,&to);//需要用树状数组吗?
        for(int ii=0;ii<n;ii++){
            if(stu[ii].age>=from&&stu[ii].age<=to)
                sv.push_back(stu[ii]);
//            if(sv.size()==no)break;
        }
        printf("Case #%d:\n",i+1);
        if(sv.size()==0)printf("None\n");
        else{
            sort(sv.begin(),sv.end(),cmp);
            for(int j=0;j<no&&j<sv.size();j++)
                printf("%s %d %d\n",sv[j].name,sv[j].age,sv[j].worth);
        }
    }

    return 0;
}
View Code

 代码来自:https://www.liuchuo.net/archives/2255

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
struct node {
    char name[10];
    int age, money;
};
int cmp1(node a, node b) {
    if(a.money != b.money)
        return a.money > b.money;//首先根据财富排序
    else if(a.age != b.age)
        return a.age < b.age;//再根据年龄排序,
    else
        return (strcmp(a.name, b.name) < 0);//再根据姓名排序
}

int main() {
    int n, k, num, amin, amax;
    scanf("%d %d", &n, &k);
    vector<node> vt(n), v;
    vector<int> book(205, 0);
    for(int i = 0; i < n; i++)
        scanf("%s %d %d", vt[i].name, &vt[i].age, &vt[i].money);
    sort(vt.begin(), vt.end(), cmp1);
    for(int i = 0; i < n; i++) {
        if(book[vt[i].age] < 100) {//根据年龄来。
            v.push_back(vt[i]);//就算这个年龄的人多余100,那么也不会输出,M最大为100.
            book[vt[i].age]++;//将其整理到一个新的数组里,按照这个进行查询输出。
        }
    }
    for(int i = 0; i < k; i++) {
        scanf("%d %d %d", &num, &amin, &amax);
        vector<node> t;
        for(int j = 0; j < v.size(); j++) {
            if(v[j].age >= amin && v[j].age <= amax)
                t.push_back(v[j]);
        }
        if(i != 0) printf("\n");
        printf("Case #%d:", i + 1);
        int flag = 0;
        for(int j = 0; j < num && j < t.size(); j++) {
            printf("\n%s %d %d", t[j].name, t[j].age, t[j].money);
            flag = 1;
        }
        if(flag == 0) printf("\nNone");
    }
    return 0;
}

//本题的考点主要就是如何不超时。

1.利用了题目中的信息 M≤100,那么由于N的级数比较大,10^5,对每个年龄的人,如果人数超过100(当前的人已经按财富排好序了)那后后面的人可以舍弃,不会输出

//学习了

猜你喜欢

转载自www.cnblogs.com/BlueBlueSea/p/9544670.html